Sunday, October 30, 2005

Request for help.

Ok guys here's the deal... This plugin doesn't work in 1.5B2, the context menu's don't show up. If anybody is willing to look at the code and make some changes to it or tell me what I need to do to make it compatable with 1.5B2 I would appreciate it.

My desktop computer is down so I don't have easy access to a machine running 1.5b2 and don't really want to intall it on my work laptop.

Please post comments here or email me at Doug0716, you can reach me via gmail (in my attempt to avoid spam... put 2 and 2 together hehe)

-Doug

7 Comments:

At December 20, 2005 7:10 AM, Blogger Dirk said...

Hi,

looked at the code, i hoped i packed the xpi right..


the only thing i found out now is this line in JavaConsole:

No chrome package registered for chrome://anonymouser/content/anonymouserOverlay.xul.


Just changed Version to test it in 1.5!

-Dirk

 
At December 20, 2005 7:14 AM, Blogger Firefox Plugins said...

Most of the code is compatible with FireFox 1.5.... I have a version compiled that works with 1.5, however now it doesn't work with 1.0.7 which I still currently use (because I'm not happy with 1.5) so I don't want to release it yet.

Feel free to get it to work with 1.5 by yourself as long as you know the proper usage of the plugin (it doesn't ALWAYS anonymize things... you right click on a link and there are two selections "Open with Anonymouser" and "Open with Anonymouser in New Tab").
-Doug

 
At December 20, 2005 7:34 AM, Blogger Dirk said...

Hi,

yeah checked it with the NightlyBuilds Plugin to turn off compatibility. And the Error still is:

No chrome package registered for chrome://anonymouser/content/anonymouserOverlay.xul .

So i packed it right! :)

Now i will see waht the chrome error is, goggled for it but...

Damn, they must have changed a lot with the installer in 1.5. Can you give me a hint?

Normaly i code in Java,Python, or C++. XUL looks easy, the code of your xpi too. But i hate this packing xpi and surounding stuff! :(

Can you give me a hint on this chrome error?

Thanx. :)

 
At December 20, 2005 7:39 AM, Blogger Firefox Plugins said...

Well, that overlay issue is probably due to the folder layout... which changed completely. I changed the whole folder structure and I think that's why I'm still having problems with the 1.0.7 because I must have missed something that 1.5 doesn't care too much about or whatever.

If you want to give me your email address I can send out the working version that I have for 1.5. You can post it in a comment and then delete it, I'll get an email with the content before you delete it so I'll have it.
-Doug

 
At December 20, 2005 7:43 AM, Blogger Dirk said...

This comment has been removed by a blog administrator.

 
At December 20, 2005 7:54 AM, Blogger Dirk said...

mmhhh.. looks like the chrome.manifest and em:file... the search goes on... :)

 
At December 20, 2005 10:23 PM, Blogger Firefox Plugins said...

Your email address bounced back...

 

Post a Comment

<< Home